Between June 1, 2026, 23:00 UTC and June 4, 2026 04:11 UTC, customers experienced delays in Dependabot scheduled version updates.
Pull request creation for version updates was delayed, with delays increasing over time and reaching up to two days. Approximately 1.5 million repositories with active Dependabot version update configurations were affected. Dependabot security updates were not affected. The primary cause was changes to an internal platform service that routes requests for Dependabot and other services.
We mitigated the incident by deploying a fix that enables batch enqueuing of update jobs, which significantly increased processing throughput. Once the backlog was drained, Dependabot returned to normal processing times.
To reduce the risk of recurrence, we are working on tuning batch size and concurrency limits for Dependabot update job processing. We are also adding monitoring for job processing lag to enable earlier detection and faster mitigation of similar issues.
Posted Jun 04, 2026 - 04:11 UTC
Update
Job lag has recovered to within normal operating thresholds. We are declaring this incident closed and will follow up with a summary soon.
Posted Jun 04, 2026 - 04:11 UTC
Update
Job lag has recovered from a peak of 1.71 days to 9h 9m at 19:29 UTC and continues to decrease. Backlog is draining at a healthy rate with no signs of reversal. New jobs are processing on schedule. Remaining lag will continue to drain over the next few hours as queued work completes; this is expected post-incident catch-up, not active impact. We will continue monitoring and re-engage if lag trend reverses.
Posted Jun 04, 2026 - 02:37 UTC
Monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jun 04, 2026 - 02:35 UTC
Update
We have applied mitigations and are continuing to see improvements in the Dependabot scheduled version updates.
Next update in 12 hours.
Posted Jun 03, 2026 - 23:38 UTC
Update
We are preparing a mitigation for the delayed Dependabot scheduled version updates.
Next update in 2 hours.
Posted Jun 03, 2026 - 21:10 UTC
Update
Customers may see delays of up to two days in Dependabot version updates.
Dependabot Security updates are not delayed.
The team is investigating mitigations for the backlog.
Next update in 1 hour.
Posted Jun 03, 2026 - 20:18 UTC
Update
We're seeing delays in Dependabot scheduled version update runs. Our team is actively working on a fix and will share updates as the situation develops.
Posted Jun 03, 2026 - 19:43 UTC
Investigating
We are investigating reports of impacted performance for some GitHub services.