GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On June 2, 2026, between 21:54 UTC and June 3, 2026 06:45 UTC, the Spark service was degraded and users were unable to store or retrieve data for their Spark apps in one of our hosting regions. Users could still make changes to their app configuration during this time. The error rate peaked at 25% of affected requests to the service. Impact was limited to users whose requests were served through a single affected region; 43 users experienced errors during this window.

The root cause was a configuration that referenced a service component by a fixed address rather than a dynamic service endpoint. When the component was replaced, requests could no longer reach the fixed address and began to fail. We resolved the incident by updating the configuration to use a our standard service endpoints that are resilient to component replacement. Recovery time was extended because replacing the component required overrides to a temporary deployment safeguard.

We are working to add validation that prevents fixed infrastructure addresses from being used in application configuration outside of test environments and to improve our monitoring to reduce our time to detect.
Posted Jun 03, 2026 - 06:46 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jun 03, 2026 - 06:45 UTC

Update

We are investigating reports of issues with service(s): Spark. We will continue to keep users updated on progress towards mitigation.
Posted Jun 03, 2026 - 06:02 UTC

Update

We are investigating reports of impacted performance for some GitHub services.

---
Relevant stamps: dotcom
Posted Jun 03, 2026 - 03:45 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Jun 03, 2026 - 03:13 UTC