GitHub header

Webhook APIs and UI Degraded

Incident Report for GitHub

Resolved

On May 28, 2026, between 00:54 UTC and 01:19 UTC, some users experienced errors when interacting with the Webhooks API, including webhook delivery history and configuration endpoints. On average, the error rate was 0.28% and peaked at 0.45%. This was due to a bug that caused a single Kubernetes pod to enter a CrashLoopBackOff after receiving a 500 with an empty response body from Cosmos DB.

We mitigated the incident by restarting the service. To prevent future incidents, we are pushing a change to handle this response scenario from Cosmos DB appropriately.
Posted May 28, 2026 - 01:32 UTC

Monitoring

The degradation affecting Webhooks has been mitigated. We are monitoring to ensure stability.
Posted May 28, 2026 - 01:27 UTC

Investigating

We are investigating reports of degraded performance for Webhooks
Posted May 28, 2026 - 01:13 UTC
This incident affected: Webhooks.