GitHub header

Auth issue resulting in API impacts, including some Slack and Teams channel subscriptions

Incident Report for GitHub

Update

We are still exploring options to restore the deleted subscriptions, and we will provide another update soon. In the meantime, customers can manually re-subscribe their Slack and Teams channels to repositories.
Posted Jun 05, 2026 - 18:43 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jun 05, 2026 - 18:05 UTC

Update

During 14:49 UTC to 16:45 UTC, customers may have experienced authorization failures for legitimate requests. This was caused by a recently enabled feature flag, which has now been turned off as a mitigation. Customers should now see normal authorization behavior. This is also the cause of the chat integration issue, and we are exploring options to restore it. In the meantime, customers can manually re-subscribe their repo.
Posted Jun 05, 2026 - 18:04 UTC

Update

Customers may see unexpected repo unsubscription events in their Slack or Teams channels.
Posted Jun 05, 2026 - 17:25 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Jun 05, 2026 - 17:20 UTC